I had this in twitter, but searching twitter failed, so i’m putting this here for when I setup a LAMP development machine again:

apt-get install apache2 php5 libapache2-mod-php5 php5-cli mysql-server php5-mysql phpmyadmin bzr git

Oh and emacs or gvim or whatever editor you use.